Welcome, Guest. Please login or register.
Did you miss your activation email?
March 20, 2018, 08:20:53 PM
Home Famicom World Search Calendar Login Register

+  Famicom World
|-+  Family Computer
| |-+  Technical & Repair Assistance (Moderators: manuel, L___E___T)
| | |-+  Sharp Twin Famicom dead
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: Sharp Twin Famicom dead  (Read 1794 times)
Posts: 3

« on: November 09, 2017, 03:27:35 AM »

I had replaced the caps on my twin famicom, but it didn't work post cap replacement.    Cap replacement went pretty smoothly except the pad came up on C123 on the anode(+) side.   I picked up another cheap twin famicom is hopes I might be able to figure if I missed something.    It had the similar low audio with buzzing that my previous (green) twin did.    Looking at the other twin (old red) I can't see where C128 goes as there is no visible trace to fallow to bridge the conection.

Where is it (C123) supposed to go?   

I would prefer to rescue my green twin as the green has the turbo feature and power indicator, where as the old red one does not.
When I turn on the switch the red(power) LED and just a blank/black screen.       The is not a no signal message so it's trying to do some thing.
Then when I switch over to disk I get the same thing, only I can hear a slight buzzing.    Anything else I can check?
Global Moderator
Gender: Male
Hong Kong Hong Kong
Posts: 6815

Hardware Collector

« Reply #1 on: November 09, 2017, 08:41:07 PM »

Really sorry to hear this Sad

I'm going to move it to the tech help section where it should get the right eyeballs on it.

Hope you can find good help with it there...

My for Sale / Trade thread
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!