Perfect picture, loud buzzing sound. not controller #2,been cleaned and unhooked

Started by SandyG, March 06, 2018, 06:07:53 am

Previous topic - Next topic


i have searched high and low for the answer. my famicom has a perfect picture but a very loud buzzing sound. i have cleaned the volume contacts on controller 2 and also unhooked the controller completely. when i blow in the microphone or adjust the volume on it makes no changes. i have not av modded it yet. i looked as far back as i could in the archives and cant find answers to this. any help would be greatly appriciated. 


That's probably the issue of connecting it via RF.

Otherwise check all capacitors/resistors or traces from CPU Pin 1 and 2 or try mod your famicom (AV, RGB, whichever you prefer).


Be sure to use a good quality RF cable. I suggest a 3' well shielded cable like a Subwoofer cable or good quality grounded audio cable. I done this and discovered all my famicom RF issues went away on any console I test (I tested 9 yesterday) also if the serial number prefix is HC they work on channel 95 with famicom set to 1 but if the serial number prefix is H only they work best 96 famicom set to channel 2. RF looks as good or better than AV mod if connected properly with proper cables. Use a RF-F connector with turns a Coaxial connection to a s simple rca connector to eliminate any need for switchboxes which allows for short good quality cable selection like I mentioned. As Iceman said it might be a bad capacitor so look for any bulging caps if you haven't already but sometimes they look fine when bad.


Check all connections from controller 2 to motherboard as well using a multimeter and check all cables for shortages between each other



Have you tried another power adapter? Aren't you using a "switching" power supply?


i have ordered a voltage converter and a "official" famicom power supply. which is my last ditch effort before testing/changing capacitors/resistors or traces from CPU.  still working on the soluton, ill will give updates as soon as i figure out something



I'm having the same problem, I tried the screws on the board and RF. It didn't work. Suggestions?