Rgb modded twin famicom no controller signal

Started by Khromak, February 12, 2019, 07:57:40 am

Previous topic - Next topic


Hey all, I'll try to keep this brief while still providing the relevant info.

I recently purchased a twin famicom which works great except the controller doesn't work in either mode. I have tried multiple games and the seller said it worked before he shipped it. I opened the console abs controller, cleaned it out and tested continuity with a multimeter, the wires all matched famicom mainboard to controller board. On the inside of the system everything seems clean, neat, and there aren't any loose wires or anything.

Any advice on further troubleshooting?


Open the controllers and clean the PCBs with isopropyl alcohol, then let it dry.

Both controllers doesn't work?


I have opened the controller and cleaned both the board and rubber pieces with alcohol. It's hard to tell if controller 2 works since it doesn't have a start button and most games require you to press start to get anywhere. 1st controller definitely doesn't work, at least the start and select buttons


I see, so it could be just the controller I START button that is broken.
What games did you test with?
If you happens to have Family BASIC or FDSStick it would be possible to test all buttons on both controllers (a flashcart like the Everdrive requires pressing START so it won't work of course).

You might need to try replacing controller I with one that is known to work, or try the controller in a Famicom that is known to work. Famicom and Twin Famicom controllers are cross-compatible I believe.


So I can't be 100% certain, but I'm 99% sure at this point that the "controller issue" I was experiencing was a user error. After messing around with it some more, I've found that if I press hard enough, the button works every time. The start button just requires a firm press to work, not like the other controllers I'm used to. Could be that this one is just worn down, or a difference between NES and Famicom controllers, but either way, it's not a technical issue, just a ID10T error.


I have SNES controllers where START hardly never works on no matter how much cleaning I do. SELECT is also in poor condition. Since all other buttons works I suspect the rubber is worn down.

Replacement parts for NES controllers are easy to find and are compatible with Famicom controllers if you want to replace the rubber buttons.


What if you test the controllers with an Arduino UNO or something like that? Helped me a lot to debug these kind of issues  :)
Check https://www.allaboutcircuits.com/projects/nes-controller-interface-with-an-arduino-uno
Just an idea
Yeah, sure