AV Famicom suddenly stopped showing picture / won't boot games now

Started by naadofett, May 23, 2023, 11:47:38 pm

Previous topic - Next topic


Hey everyone.I've got a AV Famicom and yesterday a game was powered up and working fine. Then for some reason about 15 minutes later the picture just died and I can't get it back. It's not the official HVC-002 power adapter since I tried that on my SNES without a problem. I tried multiple game carts and a brand new everdrive n8 and nothing works. I can see the everdrive blinks an LED on for a second, but nothing boots. I noticed that if I listen very carefully, I can hear a faint clicking sound near the rear of the unit if I flip the power switch on/off. Some kind of relay? I don't know if this sound is normal or not.

I tore the console apart today, but I didn't notice anything visually that seemed obviously wrong. I didn't notice any fat capacitors or anything that looked like a capacitor was leaking out of the bottom. As far as I can tell, everything looks quite clean and great condition.

I did do the Tim Worthington RGB/component video mod several months ago, but everything had been working fine until last night. I didn't touch anything other than literally sliding the power button on/off the last couple days.

I was thinking about re-capping the system and/or replacing other parts if recommended since I can handle soldering/desoldering myself. I'm located in Japan though, so I'd rather not buy recap kits from the US as shipping would be crazy expensive. I could source parts from digikey Japan if I knew exactly what to look for.



Do any chips get hot to the touch and have you tried removing the rgb mod and test the console stock.


Good questions. I'll have to plug it in and see. Should all the chips normally run cool?



Thanks. I'll have a look at that tomorrow since it's late here in Japan. I may snap a couple pictures while I'm in there too. Thanks for the advice so far.

I can't imagine there is any sort of catastrophic failure since it was literally working fine the last several days and then just crapped out yesterday. Like I said, the RGB mod itself had been working just fine for months, so I have a hard time imagining that's the source.


Well, I took the console apart and turned on the system to check chip temps (by hand). The PPU did get warm, but not blazing hot. So, I figured that was okay. Next, I took the PPU out of the Tim Worthington RGB mod and popped it back into the NES board and fired it up with composite video. I got picture again - so, good news.

Then I decided to put the PPU back into the RGB mod and try again and, for whatever reason, it fired up again and I get video through component again.

I literally have no idea what happened, but I've been running a game for a couple hours now just for testing and so far so good. I'm going to keep my fingers crossed. I have no idea why the issue would've popped up in the first place though.


Awesome it's working again,maybe the pin headers got misaligned but that's just a guess.


Well, I'm not sure if I'm out of the woods or not yet. Once I got it working yesterday morning, I just left it on ALL DAY just to see if it would totally crap out. It seemed to be fine after many hours of displaying video. That said, I wasn't watching the screen every single minute. It definitely didn't cut out completely like before though.

So, last night I was streaming using the same system (still not shut off since earlier in the morning) and everything was fine until ~3 hours into the stream. The video on my monitor and stream capture both cut out for a few seconds, then was fine for a minute or so and then did it again. It happened 3-4 times within about a 10 minute span. After that, it was okay for the remainder of the stream (~1 hour more or so).

Twitch VOD below - Skip to 3:33:11

Now, my NES feeds a component video matrix with component out to two Retrotink 5x's - one for stream and one for my monitor. So, when I got the black screen, it means one of the following:

1) Something wrong with my component video matrix (doubtful)
2) Something weird happening with BOTH retrotinks at the same time (super doubtful)
3) The NES acting up again (very likely)

I'm not sure what to troubleshoot. Clearly the NES isn't dead, but it does seem like there's some component in there that's being flaky and might need replacing.



To rule out your retrotink and switcher I would hook up the fami straight to your tv and just leave it on for a few hours to see if you can replicate the problem.


Unfortunately, easier said than done. I don't have a TV or other display that has composite or component inputs on it. Everything is HDMI on my devices :/


I'm thinking I'll recap the system to be safe (it's cheap, easy and the caps are old anyway). I can't imagine any of the main chips on the board are bad since it actually seems to function mostly normal. Maybe something happens when the console heats up more and one of the caps gives out.

If it's not caps or the main chips, any other ideas what might be causing it?


Recapping should be fine,just make sure to get good quality caps.

As for your fami,I would go over it thoroughly,make sure all of your soldering is good on the rgb mod,as for your question if anything else could cause this issue,maybe a faulty 7805 but that's most likely not.


In an interesting twist, I was doing a stream last night using my SNES and guess what happened... Same crazy (but even worse) screen blanking. I found it highly unlikely that suddenly my SNES was having issues too. After a bunch of live troubleshooting last night, we removed my 8x2 component matrix out of the loop and suddenly the extreme flickering seemed to disappear. That said, I still got a little bit of infrequent frame dropping on my capture side, but not gameplay monitor side. So, now it seems most likely that the capture card is just freaking out about refresh rates at times from the retrotink. I was probably just having two different problems having simultaneously (capture card issue + component matrix issue).

My feeling is that my consoles are actually just fine, but I'm going to be keeping an eye on them.


 Glad you have it fixed now,your consoles should be fine,I wouldn't worry about them.

 For you component matrix,does it use a external psu,if so maybe try a different one.