Technical and Repair Assistance

Started by b3b0palula, September 10, 2006, 01:08:43 am

Previous topic - Next topic


So I think I'm going to get a multimeter right now and take a look at the Famicom.  Thing is, I'm not sure how to remove the shielding myself since it's screwed on from underneath and there isn't much room to work with there.


Quote from: funkdoc on July 09, 2011, 12:35:15 pm
Solutions to damaging your system?  What kind of info would be included in this sticky?

My situation is a bit unique - I'm supposed to play Wai Wai World on a Japanese stream a week from now, but I am not sure how to go about repairing the Famicom (see pics and my previous posts above).

EDIT: That converter I received is actually an FC->NES one so never mind there.

Post Merge: July 09, 2011, 04:45:17 pm

OK, an update on the fried AV Famicom from page 97:

There's a local game store that does repairs, and we replaced the voltage regulator with a fresh new 7805 from Radio Shack.  However, it still won't turn on at all.  We had also looked at the capacitors, and none of them were leaking.  On the plus side, he didn't charge me since it isn't working - very nice guy and cool place he has!

So, where do I go from here?  Would love to get this fixed ASAP, since I'm supposed to speedrun Wai Wai World on stream in a week and am also borrowing someone's Japanese Castlevania 3 cart to do a speedrun for SDA...

EDIT: A friend of mine who's familiar with these things thinks it might be an issue with the board itself since there's sticky stuff on it.  Any ideas there?  Also, someone else said if there's a fuse it's blown - does the AV Fami have anything like that?

The VCCI Famicom has a fuse, and I think all models after it, including all revisions of the new (A/V) Famicom have one as well. You should check for this along the path of the VCC conduit from the 7805 to the rest of the PCB and also on the input-end of the 7805. I don.t recall off-hand where it is in either the NFC and SFC models, though II should

If I get a chance, I'll check.

The sticky substance could be anything: From isotonic spillage (e.g. Pepsi) or leaking capacitors (unlikely) See if it dissolves in hot water, or reacts to baking soda on a Q-tip. You need to determine the PH of the substance if you want anyone to ID it from appearance: I'd wager on some beverage becoming one with the force of your system. In such a case, there may be other internal damage, and as you do not know if it worked before using an 9VAC power supply on it, it's pretty difficult to offer any real opinions on it.
You should test to see if the VCC signal is reaching any of the system components. Look up the pin-out for the PPU ans CPU and use a multi-metre to check conductivity and current between the +5VCD pins on these components and ground (CE).   :bomb:


July 10, 2011, 08:29:24 am #1442 Last Edit: July 10, 2011, 01:23:55 pm by funkdoc
OK, here's the part I forgot to explain, which is apparently the weirdest thing about all of this:

The Famicom worked the first day I had it.  Yes, even with that AC adapter, I was able to play Wai Wai World for a bit over an hour.  Furthermore, the following day, I managed to turn it on again and did one complete playthrough (~40 minutes).  There were no other problems with the Famicom while it was working.  When I turned it off after that, it was RIP.

This is why I'm beginning to wonder if there isn't a deeper issue with the motherboard or something - I haven't seen another example on here of anyone playing a complete game with the wrong AC adapter.

One other idea: I notice a green part to the right of the reset button which looks like a capacitor but doesn't have a lid like them.  Is that normal?

Thanks for the help!

Post Merge: July 10, 2011, 10:57:17 am

Update: got the multimeter, it appears to work fine, but I don't know how exactly I'm supposed to use it with the Famicom board.  I know it's supposed to be plugged in, but do I check the front or underside of the board?  I can't remove the metal heat sink (got one last screw that won't budge with anything I have) so I have no idea how I'm supposed to be able to get these things to reach the 7805.  Thanks in advance!

Post Merge: July 10, 2011, 12:32:39 pm

Never mind about the last part, I was able to test the 7805 and it's working perfectly.

I cleaned all the gunk (agreeing more and more that it's probably soda) off the board and happened to notice something else suspicious:

EDIT: OK, I guess that stuff isn't soda after all.  It smelled burnt as I cleaned it off the board, and I noticed there are little ridges (like you'd see in folded plastic) on the board.  I question whether this thing can be saved at all...


Update: I can confirm that Mega Man 2 error does not happen on my NES powerpak. Something else is going on. Perhaps dirt remaining I failed to remove?


Hello everyone.  :)
(From the start, excuse my english, maybe I sound weird, it's not my birth langage).
So, this question have been already asked but even if I searched here I didn't really find my answer.

I just bought from ebay a modded AV famicom (the original Famicom but with an AV output) and I was very happy but it doesn't work on my TV.
It's a CRT Tv, I live in Canada, so it's a NTSC Tv, like in the USA.
The console show a really bad picture on the screen, the colors seem to be messed up and the picture not always shows itself (I got a black screen sometime). The picture is quite wavy too.
The sound is alright.

My Famicom is modded to support AV, the AV cable is linked into the system (so it's impossible to unplug it and try another one).
My Tv can display a japanese N64 just perfectly.

I really hope there is some way to fix this !  :(
If you need more infos, just ask. Please help me !  :-[
I can provide photo of the screen to show you or photo of my system.

Thank you !


Likely enough, it was improperly modified. That, or it was damaged in handling when importing it from Nippon, or from wherever you purchased it.  :bomb: