Famicom controller not work after av mod jailbar removal

Started by siubdaib, April 22, 2015, 11:54:03 pm

Previous topic - Next topic


I recently bought a Famicom from Japan with original RF board. It is HVC-CPU-GPM-02B. Meanwhile, I also bought an AV mod unit from China and completed the mod without problem and can play game with 1P & 2P controller normally.

As to remove the jailbars after the AV mod according to this japanese site http://vaot.mydns.jp/fc/noise5.htm, I further added 10 x 1.5uf capacitors. The picture quality really improved a lot. Video and audio are working great. But then the controller buttons becomes not functioning at all.

Tests that I have tried:-
1) Disconnect a good 1P controller from another good famicom and connect on the 1P port of the faulty famicom. But the controller is still not working.
2) Connect the 1P controller from the faulty famicom to 1P port of the good famicom and it works.
These seems rule out the possibility of a faulty 1P controller.

Meanwhile, I don't have an external controller that can be used to plug in the front 15-pin extension port for testing. Actually, I'm not sure if it is only the 1P start button that is not responding, or the whole 1P controller has problem, or even the 2P controller has problem, as I cannot test all the buttons before I can start a game.

I searched the web and found not much resources related to this symptom. Some said it is probably due to problem in either the 40H368 or the CPU. I have some questions that would like clarify.

1) I cannot buy 40H368 now but I can find the MC74HC368N. Can I use MC74HC368N instead of 40H368 for the replacement?
2) For the CPU, is it possible for the CPU to become faulty in the way that only the controller is affected but not other functions (i.e. video and sounds are normal)?
For replacement, can I use RP2A03H instead of RP2A03G? Besides, can it be replaced with a UA6527 I found in China website?
3) Is there any other possible cause for this issue?

Sorry for asking so many quesitons. Thanks all for the help in advance!


What do you mean by "AV mod unit?" An AV mod requires only a few caps and a couple of RCA connectors; there's no need to go around putting units in things. If you bought some pre-made board or something, I would be suspicious of that. Don't trust something you didn't build yourself.


I would try to remove the caps you have put in and see what happens.

Did you maybe damage some trace on the circuit board, or short circuit something?
Selling  Japanese games in Sweden since 2011 (as "japanspel").
blog: http://japanspel.blogspot.com


After I removed one of the caps, the controllers work flawlessly now, and the picture without any jailbar.  Thanks!


Nice!  Which one was it?  So, you changed 10 of the 0.01uf out to be 1.5uf?


I added the 1.5 uf caps parallel to the original 0.01 uf caps.  For C36, I did not add the 1.5 uf as it cause the controller to not function.


This mod looks interesting, I'd like to try it but I can only find electrolytic or tantalum capacitors for 1.5 uF. Will these be OK, provided that I install them respecting the polarity?