New Forum Version

Started by UglyJoe, January 18, 2020, 04:51:24 pm

Previous topic - Next topic

UglyJoe

Hey, so the forum software we're using is old.  Like, really old.  Like, not updated anymore old.  It's so old, the version of PHP that it requires isn't even supported any more.

So, my webhost is forcing PHP to be upgraded.  This makes sense from an IT perspective since the old version wont' get security updates anymore and they can't have sites getting hacked all over the place.

Unfortunately, this means that we need to update our forum software, as well.  I do like this old look-and-feel, but not enough to find new hosting to continue running outdated software that will probably get hacked because of unpatched security issues.

The webhost will be updating things on Jan 22, which is in the middle of the week, so I am going to force the upgrade tomorrow (Sunday, 1/19) and do the upgrade.

I have done a sort of "dry run" using a copy of the forum running in a VM, so I am aware of some of the hurdles I'll run into.  I'm sure there will be some other weirdness, though.

So, if you see things in "maintenance mode" or find yourself logged out or whatever, this is why.

If you get totally stuck after the upgrade, you can contact me at uglyjoe@famicomworld.com or yell at me on Twitter @ximwix.

After things are up and running again, I'll be patching things up all over the place.  I'm sure there are going to be things to add/fix.

tl;dr - the forum software is going to be upgraded Sunday 1/19, so expect downtime and then major differences

Fingers crossed ;D

Flying_Phoenix

Good luck to you and the forum! Hope to see it back up soon :)

dado2095

I will miss the old look of the forum, but this and more to keep it operational and safe!
I wish you a good job, see you on the other side!  8)

UglyJoe

January 19, 2020, 11:31:50 am #3 Last Edit: January 19, 2020, 11:38:27 am by UglyJoe
It's upgraded!

Hopefully you can all still see this and can login and do things as you normally would.  If anything seems messed up or is flat-out broken, please let me know!

Post issues here, please: https://www.famicomworld.com/forum/index.php?topic=14703.0

xIceMan

New look, need to get use to it, but glad it's being upgraded and seems to be working for now!

Are there any chance to get old theme back or customize one to get it similar? Or perhaps new ones?

UglyJoe

I'm still working on the theme.  I won't be able to get it back to the old theme since there is actually a lot that has changed with the software.  This theme has pretty good bones, though, at least as far as responsiveness goes (that is, it won't look like crap on mobile).

xIceMan

Yea, agree, but for some reason the posting toolbar doesn't display anything for me (yet).
Using Firefox latest stable build.

EDIT: Regular replying or modyfing posts is the same.

UglyJoe

Quote from: xIceMan on January 19, 2020, 11:41:32 amYea, agree, but for some reason the posting toolbar doesn't display anything for me (yet).
Using Firefox latest stable build.

EDIT: Regular replying or modyfing posts is the same.

That should be fixed now!

xIceMan


FAMICOM_87

WoW new GUI!  :o  but I miss the old one   :-[

nguyenbakhaihoan

After this upgrade we can use tapatalk with this forum. It will be better for people who browse the forum via mobile phone

Sent from my SM-N950N using Tapatalk


UglyJoe

Quote from: nguyenbakhaihoan on January 19, 2020, 05:46:15 pmAfter this upgrade we can use tapatalk with this forum. It will be better for people who browse the forum via mobile phone

Sent from my SM-N950N using Tapatalk
Tapatalk worked with the old forum version, as well.

famiac

Man, I knew this day would come. Thanks for putting in the effort to restore some of the old aesthetic.
member #844 and 565

UglyJoe

Quote from: famiac on January 20, 2020, 01:16:21 pmMan, I knew this day would come. Thanks for putting in the effort to restore some of the old aesthetic.

Thanks.  Still working on it!

Ghegs

End of an era (of sorts), but thanks to UglyJoe for keeping the place up, running and updated.
My videos
Rolling Start!! - Arcade Racing Game Forum