Something that annoys you

Started by ericj, June 06, 2008, 05:22:35 pm

Previous topic - Next topic

Jedi Master Baiter

W00H00! ;D Bought one! ;D

Also, my package from Krikzz came in exactly as I ordered: a Super EverDrive X5 and an EverDrive GBA Mini as a gift for my brother for Christmas. :-X

Jedi Master Baiter

Uh oh. :( I finally tried out the Super EverDrive X5: I downloaded the files from the site, deleted the DSP directory (X5 isn't compatible), added them to the root of a new mini SD card, fired the ol' SNES up and received an error message stating the "Battery has run dry" and to replace it with a new one. :-\

When I started it up again, I didn't get this message. ??? So now it's fine? I'm going to find a battery-backed game to test this out with. Are there any test ROMs out there for this sort of thing?


Unless it happens again it might just be a one-time thing because it detected that the BBSRAM (Battery-Backed Static RAM) was corrupt the first time you started it after installing the battery. That is probably normal unless they tested it after installing the battery during the manufacturing process (so I suppose the manufacturer never tested it after doing that).

There are tons of battery-backup games like SMW or Zelda 3, but I'm not sure what there is to test. If the battery is bad you will get that error again and the save for the last game you played will be corrupt. The save should appear in the SAVE directory on the SD-card when you start another game, so BBSRAM only contains the save file you are currently using, and the saves in the SAVE directory are safe from battery failure.
It's a good idea to once in a while make backups of your SAVE directory after switching games to update it with your latest save in SRAM.

Here I'm assuming the Super Everdrive works like the Famicom Everdrive and other Everdrives though.

Jedi Master Baiter

I got the error message a couple more times. I tried NBA Hangtime to test the saving (one: because I can just create a player and see if that saves and two: I've always wanted to check out how the SNES version compares).

The battery seems to work fine: I created a character, resetted the console (even shut it off), input my name/pin, and my custom character loads. I tried it again when I received the error message and I got the "No Record" when starting a new name/pin. Just to make sure, I resetted the console again, didn't receive the error message, and my character loaded fine again. ???

I'm going to open the cart and look at the battery. They're removable, right? Maybe I should readjust or replace it?

Just to make sure, the save is currently on the SD card, but if the battery fails, the ROM cannot hold the save, and upon startup, the SD card save file cannot be overwritten, right? :-\


Odd, either they shipped it with an old or low-quality battery or there is something wrong with the hardware.

Pressing RESET is not a way to test the battery since it doesn't cut the power so the BBSRAM will not decay in that case. You need to power cycle to test this, how long you have to wait after turning it OFF depends on how long the RAM takes to decay which may vary depending on brand, temperature, moon phase etc (OK maybe not so much moon phase). I doubt you need to wait more than a minute at max, but avoid doing very quick power cycles.

Yeah battery is removable on my Everdrives at least. Replacing it with the same type (CR-32 I suppose?) is the easiest thing you can try, so yeah I would try that if I were you.

I think the Everdrive detects if the BBSRAM is corrupt so there shouldn't be any risk that it overwrites the save on the SD-card. Unless it just detects low battery voltage.
Backup your precious saves to be safe.

Jedi Master Baiter

Unlike the Super EverDrive v2 the Super EverDrive X5 uses screws I don't have tools for. :( I don't even know what they are, but I think they might be torx screws. :-\

The past few days have been issue after issue with batteries: the EverDrive, my laptop refusing to recharge, our Toyota 4Runner unable to jumpstart :blinky: ...

Jedi Master Baiter

Being unable to find precision tools is annoying in itself, and the stores that seem to carry them keep closing: Radioshack, Fry's, etc.

Years back when I wanted to open my GBASP, I went to Home Depot to buy some tri-wing screwdrivers. They didn't have 'em. :upsetroll:

So this time, I went to Staples (because they carry electronics, right?) and they don't carry tools in general. :upsetroll:

I even brought in my cartridge so they could see the screws. The assoc. suggested I snap the torx screw heads off. ??? I mean, I guess I don't need the screws, right? :upsetroll:


You will have a tough time trying to screw or unscrew them without their heads though. It's possible to drill the screws into oblivion but that way the screw holes will be unusable and you won't be able to use the cartridge shell anymore if you do that with all the screws.

Strange that torx is so hard to find.
If you get it to open you could replace them for normal plus-screws if you can find the right size.

Jedi Master Baiter

It's not that torx bits are hard to find. It's that precision tools other than flathead or phillips are hard to find. Home Depot probably has torx bits the size of my... finger.

I ended up buying a 32-piece precision tool set that included hex and torx at Harbor Freight for about $7. I also bought extra CR2032 batteries.

I opened the cartridge, realigned the battery, replaced the battery, and tried this with four different batteries but still get the message occasionally on every single one of them. :-\

What can I do? :-\

Edit: I tested it without the battery at all and sometimes didn't get the message!


Hmm so the battery is fine. It might be the Everdrive or something going on with the SNES or AC-adapter I guess.


Thank you, Master Jedi, you are very helpful.